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MAKING NORTH DAKOTA PDF FORMS ACCESSIBLE IN DESIGNER 
 
 
STEP 1: ADOBE FORMS DESIGNER 
 
Accessibility requirements (i.e. tags, language, title, etc.) must be fixed directly in Adobe AEM 
Forms Designer.  Due to the underlying methods used to create the PDF, accessibility options 
can’t be changed (greyed out) in Adobe Acrobat Pro.   
 
 
1. CREATE/DESIGN FORM 

 
• Images/Logo: Add alternative text to describe (i.e. State Seal, Agency logo)  

a. Select the logo on Master Page 1 and click on Accessibility tab.   
b. Set Screen Reader Precedence=Tool Tip and add the name or description of the 

logo to the Tool Tip area.  

   
 

• Title Block: 
a. Add Title Block (requirements and example in “Forms Design Accessibility 

standards” (Form Title=14pt, bold, all caps, Agency Name=12pt, not bold, all caps, 
SFN/Date=11pt) 
NOTE: Top borders for Logo and Title block need to be at the same height to ensure 
correct reading order. 

b. Select Title Block, from Accessibility tab, set Role=Header 
 

• Labels/Captions: 
Select a form field and click on Accessibility tab.  Set Screen Reader Precedence as 
appropriate. Suggest always adding a “Tool Tip” (defaults to Custom Text) and adding 
description to Tool Tip box at the top. Warning may say “Field has no assist text”. 

 
a. Layout fields:  

o Font type/sizes for fields=Arial, 12pt label/caption and 12 or 14 fillable field 
(value), as a suggestion 

o Add fields to form identifying each field with Accessibility Role (header, caption, 
etc.) or Tool Tip (tags field to describe) 
 

TIP/HINT (for most fields): Copy and paste field label from “caption” to “binding” 
name (builds hierarchy, which is important for Reading Order), both under Object 
tab. Then paste to Accessibility tab as a “Tool Tip” for the Screen Reader 
Precedence and include action prior to label (e.g. Enter Name). 

https://www.ndit.nd.gov/sites/www/files/documents/operations-section/records-management/ada-form-standards.pdf
https://www.ndit.nd.gov/sites/www/files/documents/operations-section/records-management/ada-form-standards.pdf
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• Checkbox Fields 

For checkbox fields that require additional input from user, create a separate field for 
each response. 

 
 

• Radio Buttons:  
a. Select radio button group from hierarchy and click on Accessibility tab.   
b. Set Screen Reader Precedence to “Tool Tip” and add description to the Tool Tip 

area.   
NOTE: Each answer should be keyboard accessible rather than requiring the mouse 
to select (test using arrow keys, not tab key, under Preview PDF). 

 
• Buttons:  

a. Select the button and click on Accessibility tab.   
b. Set Screen Reader Precedence to “Tool Tip” and add the description to the Tool Tip 

area. 
 

• Tables:  
a. Select header row (top) in hierarchy and click on Accessibility tab.  Set Role as 

Header Row. 

  
 

b. Add descriptive “Tool Tip” to entry fields in a table since they won’t have captions. 

 
HINT: Select entire column to create field type (i.e. Text Field, then add description 
to both Binding Name and Accessibility tab and set screen presence to Tool Tip. 
Then select all fillable areas (mouse-click upper left, hold down shift, click lower right 
to select) and add a space in the Captions field or accept warning that there’s no 
caption for these fields.  
 

• Links: 
Right-mouse click to create URL or email links. 

o Use descriptive hyperlink text. Avoid using “click here”. 
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2. DEFINE READING ORDER FOR ACCESSIBILITY  
Set the hierarchy structure as you build the form (order in Hierarchy panel/folder – top to 
bottom): 
• Title Block: Use Role=Header 

 
• Section Dividers/Headers: Use Role=Header 1 (keep consistent, e.g. all bold, upper 

case, same font size, as an example – similar to MS Word’s Style options: H1, H2, H3) 
 

• Field Names: Select field and set Binding Name under Object folder – builds hierarchy, 
and add to Accessibility tab (set screen precedence: Tool Tip and describe) 
 
NOTE: For “Text-Only” fields: From hierarchy, right-mouse click to Rename and Select 
the dropdown next to “Role” to specify as a heading, caption, or none (“Artifact” removes 
object from reading order). Below are a couple of examples: 

 
 

NOTE: Ensure the hierarchy order follows the layout of the fields on the form 
(name, address, city, state, zip) 

 
o Click and drag fields with mouse to move up/down in hierarchy to change order. 

 
 

3. VERIFY TAB ORDER 
a. Ensure correct AEM Designer settings: 

Under Tools > Options > Tab Order, ensure “Only show tab order for fields” is 
unchecked. 
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b. Under Tab Order, use “Automatic” to reset, or “Custom” to manually set field 

order used when clicking tab key to complete form.  
c. Click field on form, then click number to activate and renumber in tab order panel 

or click/drag numbers up/down with mouse. 
 

4. SET LANGUAGE  
a. Select Page 1 in the Hierarchy (upper-most object in hierarchy, which is typically 

“Page 1”).  
 

b. From Object tab, Subform, find “Locale” and set to English (USA) –  
*see note under Adobe Acrobat Pro (section, item 3.c. language must be set in 
Adobe AEM Forms Designer, not Acrobat)  

 
 

 
5. ADD DOCUMENT TITLE 

Select File - Form Properties - Info and add Title and any other helpful information 

 
 

 
6. RUN ACCESSIBILITY CHECKER  

Found under Tools | Macros (allow access) 
a. Select Tools - Macros - Accessibility Check.  Ignore the macro warning message. 
b. Leave all boxes checked and click Ok. 
c. A PDF report of failures and warnings will be displayed 
d. Interpret Warnings for each field identified: (e.g. Add caption, image has no 

alternate text, etc.) and fix, as appropriate. 
Example: 

 
 

NOTE: Scripts may show as warnings, but if they don’t change the focus of the 
screen reader when they run, the script should be fine. 
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7. SAVE FORM:  
Once Remediation is completed (warning(s) accepted or no problems found), Save the 
form using: File, Save As, File Type=Static pdf 

 
 

NOTE: Do not make pdf reader-extended in Adobe Acrobat Pro until report has been accepted 
and attached to the form. 
 
 
STEP 2: CHECK ACCESSIBILITY IN ADOBE ACROBAT PRO 

 
The following tools can be used to check the accessibility of a form: 
• Accessibility Checker in Adobe Acrobat Pro 
• Screen reader software (e.g. Jaws, NVDA) 
 

NOTE: The above tools are not considered remediation tools to fix problems. The state will 
be searching for alternate solutions. In the meantime, remediate forms in the preferred tool 
for creating the form (i.e. Designer), then in Adobe Acrobat Pro.   
 
Final report should be approved by designated internal resource(s), (i.e. legal, 
communications, civil service office). 

 
 
1. CHECK ACCESSIBILITY: 

In Adobe Acrobat Pro, select All Tools – Prepare for Accessibility and Start Checking. 
 

a. From “All Tools”, click Prepare for Accessibility (may need to select “View More” options) 
Note: Click/drag with mouse to move up within the list of options, if preferred. 

 
 

b. Select Check for Accessibility. Keep all options checked and click “Start Checking” 
button. 
NOTE: At this point do not select “Create Accessibility report” under Report Options. 
Wait until the form is approved and remaining items accepted as fixed or remediated. 

a. A list of items passed/failed will be displayed:  
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c. Warnings displayed will need to be fixed in Adobe Designer (e.g. reading order, field 
tags, alternative text, color contrast, scripts), as determined by internal staff.  

a. If an item shows as “Needs Manual fix”, a decision needs to be made as to 
whether remediation is necessary or if acceptable to the agency as is (i.e. scripts 
may appear on every form if using the “Page # of #” as a multi-page header, as it 
is considered a script). 

 
2. VERIFY READING ORDER 

If the warning panel shows “Fix Logical Reader Order”, then check the following: 
a. Under Prepare for Accessibility, select the “Fix Reading Order” button to display the 

options to fix the field order: 

 
 

b. Click the “Show Order Panel” button (lower right side of Reading Order window, or 

icon: to display and fix reading order: 
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3. TEST AUDIO (optional) 

Click the Audio button to test 

 
 
4. GENERATE REPORT  

Select Check for Accessibility, Report Options and Start Checking (from #1. b. above) to 
determine if final report is acceptable to internal agency staff (i.e. legal, communications, 
civil service office) 

a. Settings to Create and Attach Report to Document: 

 

 
 
 

b. Icon also available to View Accessibility Report within Acrobat 
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Example:  

STEP 3: COMPLETE FORM UPDATES 
 
Make form reader-extended in Acrobat Adobe Pro, test in Adobe Reader (if available) and save 
to website. 
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CHECKLIST FOR MAKING PDF FORMS ACCESSIBLE 
 
STEP 1: ADOBE FORMS DESIGNER 
 

Create/Design Form 
□ Images/Logo: Add alternative text (Accessibility tab → Screen Reader Precedence = 

Tool Tip) 
□ Title Block: Follow ND standards; Set Role = Header 
□ Labels/Captions:  
 Add Tool Tip for each field (under Accessibility tab → Screen Reader Precedence) 
 Layout Fields: Font Arial, 12pt caption, 12–14pt fillable field; Assign Accessibility 

Role or Tool Tip 
 Tip: Copy caption → Binding Name → Tool Tip with action preceding description 

(e.g. Enter Name). Both the caption and tool tip will be read aloud by the screen 
reader. 

□ Checkbox Fields: Create separate Text field with box format, if additional response is 
required 

□ Radio Button: Add Tool Tip. Verify functionality using arrow keys, not tab key. 
□ Buttons: Add Tool Tip description 
□ Tables: Set header row Role = Header Row; Add Tool Tips for entry fields 
□ Links: Use descriptive text (avoid 'click here') 

Define Reading Order 
□ Organize hierarchy top-to-bottom (click/drag objects to move up/down); Assign/verify 

roles and/or screen precedence; Verify hierarchy matches form layout 

Verify Tab Order 
□ Set Automatic or Custom; Renumber fields or drag numbers in Tab Order panel 
 
Set Language 
□ Page 1 → Locale = English (USA) 

 
Add Document Title 
□ File → Form Properties → Info = Add title 

 
Run Accessibility Checker 
□ Tools → Macros → Accessibility Check; Fix warnings in Adobe Designer or agency staff 

determine if acceptable 
 

Save Form 
□ Save As Static PDF; Do NOT make reader-extended in Adobe Acrobat Pro until report is 

accepted 
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STEP 2: CHECK ACCESSIBILITY IN ADOBE ACROBAT PRO 
 

Check Accessibility 
□ All Tools → Prepare for Accessibility → Select Check for Accessibility → Start Checking 
□ Review items passed/failed 
□ Fix warnings, as appropriate. If flagged as 'Needs Manual Fix' an internal agency 

decision will need to be made. 
 

Verify Reading Order  
□ If indicates “Fix Logical Reading Order”, may need to Show Order Panel to see where 

order is off. Will need to be fixed in Adobe Forms Designer. 
 

Test Audio (optional) 
□ Click the Audio button to test 

 
Generate Final Accessibility Report  
□ Select Check for Accessibility, Report Options and Start Checking 
□ Determine if final report is acceptable to internal agency staff (i.e. legal, communications, 

civil service office) 
 

STEP 3: COMPLETE FORM UPDATES 
 

□ Make form reader-extended in Acrobat 
□ Test in Reader 
□ Save and publish to website 

 
 
ADDITIONAL RESOURCES: 

1. ND Forms Design Accessibility standards: 
https://www.ndit.nd.gov/sites/www/files/documents/operations-section/records-
management/ada-form-standards.pdf  

 
2. Create and verify PDF accessibility (Adobe Acrobat Pro) 

https://helpx.adobe.com/acrobat/using/create-verify-pdf-
accessibility.html?trackingid=KACNN#PrimeLang  
 

3. ND Training Hub 
 

4. Digital Accessibility Teams Channel: Digital Accessibility | -Tm-SoND-TeamND | 
Microsoft Teams 
 

https://www.ndit.nd.gov/sites/www/files/documents/operations-section/records-management/ada-form-standards.pdf
https://www.ndit.nd.gov/sites/www/files/documents/operations-section/records-management/ada-form-standards.pdf
https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html?trackingid=KACNN#PrimeLang
https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html?trackingid=KACNN#PrimeLang
https://ndgov.sharepoint.com/sites/TeamND/SitePages/Digital-Accessibility-Training.aspx?&xsdata=%3D%3D&sdata=SzFNZE9MRzdWanFqWHhUUFlOR1IwSWVMbVhCS1IyVnUzVEcrRXMxRmtFcz0%3D&ovuser=2dea0464-da51-4a88-bae2-b3db94bc0c54%2Cdcote%40nd.gov&OR=Teams-HL&CT=1769663197118&clickparams=eyJBcHBOYW1lIjoiVGVhbXMtRGVza3RvcCIsIkFwcFZlcnNpb24iOiI0OS8yNTExMzAwMTMxMiJ9
https://teams.microsoft.com/l/channel/19%3Aa1731d74068a4bf0aa5f8be03d6407e0%40thread.skype/Digital%20Accessibility?groupId=910012a9-c959-41c4-959f-96c98466aa91&tenantId=2dea0464-da51-4a88-bae2-b3db94bc0c54
https://teams.microsoft.com/l/channel/19%3Aa1731d74068a4bf0aa5f8be03d6407e0%40thread.skype/Digital%20Accessibility?groupId=910012a9-c959-41c4-959f-96c98466aa91&tenantId=2dea0464-da51-4a88-bae2-b3db94bc0c54
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